Hide in tile view for reports

Jul 13, 2012 at 8:08 AM


does someone have an idea how to set the "Hide in tile view" for reports? I get it to work on folders, but I can't configure it for reports.

In the code I see there's metadata called "ReportServerProperties", but if I add it as a parameter in the AddReport node (in the target DeployReports) I get an error, as well if I put it as a child element of AddReport.


Jul 13, 2012 at 1:00 PM

Hi Koen

    To hide a report in the default report view you need to add the following extra metadata: <ReportServerProperties>Hidden=true</ReportServerProperties> to the report item within the ItemGroup of the report you wish to hide for example : 


<ReportsToDeploy Include="$(MSBuildProjectDirectory)\ProcessReports\ProcessRunDetail.rdl">


If you are are using wild cards to create your ItemGroup  list and only have one or two reports you wish to hide you, here is an example how to do efficiently: 


	<ReportsToDeploy Include="$(MSBuildProjectDirectory)\PrcoessReports\*.rdl" 
	<ReportsToDeploy Include="$(MSBuildProjectDirectory)\ProcessReports\ProcessRunDetail.rdl">



Jul 13, 2012 at 1:25 PM

Thanks Steven, it works. I originally put the ReportServerProperties element in the AddReports node, instead of in the ItemGroup list. It seems so easy now :)

The Exclude option is also something very useful I wasn't aware of, thanks for sharing.

Aug 14, 2012 at 9:57 PM

I'm sure there is a way to hide an entire folder? Is there any documentation out there that I'm missing where I can look? I've just been digging through the one example and making some educated guesses...

Aug 17, 2012 at 6:17 AM
Edited Aug 17, 2012 at 6:17 AM

Sure, you need to add an attribute to the CreateReportFolder element. An example:

<CreateReportFolder ReportServerURL="$(ReportingServerURL)" NewFolderPath="$(ProjectReportDataSources)" FolderReportProperties= "Hidden=true"/>

Sep 7, 2012 at 8:11 PM
Edited Sep 7, 2012 at 8:13 PM

Thanks! I see it now as a comment on the documentation page as well. My bad, but I do appreciate the reply.