Deployment of shared dataset in integrated mode

Jun 5, 2012 at 2:15 PM
Edited Jun 5, 2012 at 2:16 PM

Hi there,

first thanks for this library!

Second. How can I deploy shared data sets when running in SharePoint 2010 integrated mode?

When I use

<Target Name="CreateSharedDataSet">
  <AddShareDataSets ReportServerURL="$(ReportingServerURL)" Folder="Reporting/DataSet" ShareDataSets="@(DataSetToDeploy)" />
</Target>

I'm getting errors Reporting error UploadShareDataSet: Client found response content type of 'text/html', but expected 'text/xml'.\r

Thanks and greetings

Coordinator
Jun 12, 2012 at 9:23 PM

Hi,

     Thanks for using the library.  I am not sure why you are getting the error,  I think it might due to the folder path not in the correct format.  I will take a look into it.

Coordinator
Jun 28, 2012 at 9:44 PM

Hi

  I found the problem, It was due to the folder format not being correct.  Also I found the task were not Sharepoint mode friendly.  I have now update them and the integrated mode deployment script. 

If you download the latest version of the tasks and the SSRSMSBuildTaskDemoR2.zip to see how to get the task to work with Sharepoint Report Server.

Regards

Steve

Aug 29, 2012 at 10:00 PM

I have been trying to get the Shared Datasets to deploy to SharePoint, but everything I try keeps erroring out for the ProjectDataSetFolder value.  I tried it with the R2 example you uploaded, but that doesn't seem to work quite as expected.  I can get my data sources to upload, just not the data sets.  Everytime I try to create the data sets it appears to be adding an additional "/" at the beginning of the path which generates an error.  Here is my current settings:

 <!--ReportServer-->
 <PropertyGroup>
  <ServerURL>$(SharePointSiteUrl)</ServerURL>
  <SPReportingSite>$(SharePointSiteUrl)</SPReportingSite>
  <SPDocumentLibraryURL>$(SPReportingSite)/Reports</SPDocumentLibraryURL>
  <ProjectReportRoot>MyReports</ProjectReportRoot>
  <ProjectReportFolder>$(ProjectReportRoot)</ProjectReportFolder>
  <ProjectDataSetFolder>$(SPDocumentLibraryURL)/Datasets</ProjectDataSetFolder>
  <ProjectReportDataSources>Data Sources</ProjectReportDataSources>
 </PropertyGroup>

Here is what the error keeps stating that the path of the item is not valid, full path must be less than 260 characters long, and talks about native mode must start with a slash.  Well I am not doing native mode and it keeps putting the slash in there for me and I don't want that. I am not sure why the data sets behaves differently than the data sources.  I tried just Datasets for the value, but then it errors out with the path value of '/Datasets'.

Any ideas?  I am referenceing the ssrsmsbuildtasks.R2.tasks like your example. It doesn't appear that this option is available in the integrated tasks.

Also, it appears that everything needs to be deleted first and then added, is there any option to leave the items and continue with the build process.  I have my data sources setup to not overwrite, but then it stops at that point in the process since the file already exists.  I just want it to continue on.

Thanks.

 

 

 

Coordinator
Aug 30, 2012 at 8:45 AM
Hi.
Sorry for short reply. You need to look at the integrated example within the examples as shows how to deploy to SharePoint.

Regards
Steve

Sent from my Windows Phone

From: denglishbi
Sent: 29/08/2012 22:00
To: zog_x@hotmail.com
Subject: Re: Deployment of shared dataset in integrated mode [SSRSMSBuildTasks:358404]

From: denglishbi

I have been trying to get the Shared Datasets to deploy to SharePoint, but everything I try keeps erroring out for the ProjectDataSetFolder value. I tried it with the R2 example you uploaded, but that doesn't seem to work quite as expected. I can get my data sources to upload, just not the data sets. Everytime I try to create the data sets it appears to be adding an additional "/" at the beginning of the path which generates an error. Here is my current settings:

<!--ReportServer-->
<PropertyGroup>
<ServerURL>$(SharePointSiteUrl)</ServerURL>
<SPReportingSite>$(SharePointSiteUrl)</SPReportingSite>
<SPDocumentLibraryURL>$(SPReportingSite)/Reports</SPDocumentLibraryURL>
<ProjectReportRoot>MyReports</ProjectReportRoot>
<ProjectReportFolder>$(ProjectReportRoot)</ProjectReportFolder>
<ProjectDataSetFolder>$(SPDocumentLibraryURL)/Datasets</ProjectDataSetFolder>
<ProjectReportDataSources>Data Sources</ProjectReportDataSources>
</PropertyGroup>

Here is what the error keeps stating that the path of the item is not valid, full path must be less than 260 characters long, and talks about native mode must start with a slash. Well I am not doing native mode and it keeps putting the slash in there for me and I don't want that. I am not sure why the data sets behaves differently than the data sources. I tried just Datasets for the value, but then it errors out with the path value of '/Datasets'.

Any ideas? I am referenceing the ssrsmsbuildtasks.R2.tasks like your example. It doesn't appear that this option is available in the integrated tasks.

Also, it appears that everything needs to be deleted first and then added, is there any option to leave the items and continue with the build process. I have my data sources setup to not overwrite, but then it stops at that point in the process since the file already exists. I just want it to continue on.

Thanks.

Aug 30, 2012 at 12:34 PM

I have tried the setup like displayed in the example (SSRSMSBuildTaskDemoR2_Integrated.msbuild) but that does not work, I continue to get the error message and always appends the additional slash at the beginning of the output in the error message.  If I use the example approach and use the $(ProjectReportRoot)/Datasets then I get that the path value '/MyReports/Datasets' is not valid.  If I use the $(SPDocumentLibraryURL)/Datasets then I get '/http://server/Reports/MyReports/Datasets' is not valid.  The data sources is working fine, just don't understand why the datasets portion is not.

Aug 30, 2012 at 4:23 PM

I will have to review my setup.  I ran the SSRSMSBuildTaskDemoR2_Integrated.msbuild sample against one of my VMs and everything completed without any errors.  I must have made a modification to the file that is causing some issues. Thanks.